Delays in order placement and executions on Malta Stock exchange
Incident Report for CCTrader™
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 10:50 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 04, 2021 - 09:59 CEST
Investigating
We are currently investigating order placement and execution delays for instruments traded on the Malta Stock Exchange
Posted Oct 04, 2021 - 09:59 CEST
This incident affected: CCTrader Open API (Live) and Trading Platform (live.cctrader.com, iOS & Android apps) (Trading).