Slowness in order updates on Malta Stock Exchange
Incident Report for CCTrader™
Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 10:10 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 16, 2021 - 17:28 CEST
Update
Root cause investigation is ongoing. Trading is operational however.
Posted Apr 16, 2021 - 14:39 CEST
Update
Intermittent delays in order placement still being investigated.
Posted Apr 16, 2021 - 13:32 CEST
Investigating
We are currently investigating this issue.
Posted Apr 16, 2021 - 10:21 CEST
This incident affected: CCTrader Open API (Live) and Trading Platform (live.cctrader.com, iOS & Android apps) (Trading).